Intermittent Timeouts
Incident Report for RevCascade
Postmortem

This was affecting a very small % of requests, but ended up being caused by an excess of idle Redis connections from AWS Lambda workers. Clearing out the idle requests solved the issue.

Posted Jan 29, 2020 - 05:14 UTC

Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 19:50 UTC
Monitoring
The fix has been implemented. We will continue to monitor to ensure the issue is resolved.
Posted Nov 22, 2019 - 18:35 UTC
Identified
We have identified an issue that is causing intermittent timeouts and will be addressing it shortly. It may result in a brief outage of console and API requests.
Posted Nov 22, 2019 - 18:30 UTC
This incident affected: Production (API, Console).