API Unreachable
Incident Report for RevCascade
Postmortem

We failed to get a network interface when performing the database upgrade which resulted in the DB entering a permanently failed state. Though it was still operational, it would not be recoverable from its state so we had to disable incoming API writes while failing over to ensure data integrity.

Posted Jan 29, 2020 - 05:12 UTC

Resolved
All components are fully operational.
Posted Oct 03, 2019 - 09:48 UTC
Monitoring
A fix has been implemented and the API should be fully functional. The console and other ancillary scheduled processes will be ramping up shortly.
Posted Oct 03, 2019 - 09:15 UTC
Investigating
Complications resulting from our database upgrade has caused our database to be unreachable. In the interest of protecting data integrity while we repair the database, we have disabled all API requests.
Posted Oct 03, 2019 - 04:07 UTC
This incident affected: Production (API, Console).